Spanish for Educators

16 Hours / 6 Months / Self-Paced

Course Overview:

Spanish for Educators is a self-paced, on-line occupational Spanish conversation course that seeks to bridge the communication gap between English and Spanish speakers. This course is ideal for teachers, administrators, and anyone working with Spanish-speaking students and parents.

Students will build their workplace Spanish vocabulary and conversation skills while learning with pictures, native-pronunciations, readings, and quizzes, as well as cultural tidbits along the way.

Course Outline:

Spanish Fundamentals:
  • Introduction
  • Greetings
  • More Greetings
  • More Conversational Phrases
  • Survival Words
  • Numbers 0-9
  • Numbers 10-1000
  • Colors
  • Directions
  • Places
  • Questions
  • Time
  • Months & Seasons
  • Days of the Week and Date
  • Family
  • Personal Characteristics
  • Likes and Dislikes
Spanish for Educators:
  • Introduction
  • Job Titles
  • Receptions
  • Registration
  • Places
  • Essential Phrases
  • Classroom Objects
  • Action Verbs
  • Commands
  • Behavior
  • Study Skills
  • Courses
  • Expressions for Younger Students
  • School Rules

All necessary materials are included.


System Requirements:

Internet Connectivity Requirements:
  • Cable and DSL internet connections are recommended.
Hardware Requirements:
  • Minimum Pentium 400 Mhz CPU or G3 Macintosh. 1 GHz or greater CPU recommended.
  • 256MB RAM minimum. 1 GB RAM recommended.
  • 800x600 video resolution minimum. 1025x768 recommended.
  • Speakers/Headphones to listen to Dialogue steaming audio sessions.
  • A microphone to speak in Dialogue streaming audio sessions.
Operating System Requirements:
  • Windows Vista, 7, 8, 8.1, 9, 10
  • Mac OSX 10 or higher.
  • OpenSUSE Linux 9.2 or higher.
Web Browser Requirements:
  • Google Chrome is recommended.
  • Firefox 13.x or greater.
  • Internet Explorer 6.x or greater.
  • Safari 3.2.2 or greater.
Software Requirements:
  • Adobe Flash Player 6 or greater.
  • Oracle Java 7 or greater.
  • Adobe Reader 7 or greater.
Web Browser Settings:
  • Accept Cookies
  • Disable Pop-up Blocker.


** Outlines are subject to change, as courses and materials are updated. Software is not included with the purchase of the course, unless otherwise specified. Students are responsible for the purchase and installation of the necessary course software. **